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I. Review
a. Defining and Publishing a Site

b. Cascading Style Sheets (CSS)

c. Div Tags

d. CSS Rules

e. External/Internal Style Sheets

f. Tables

II. Define a Site with Host Information

We will be creating a new site and, similar to the first two courses, will need to define the site for file management purposes. At the end of this course we will be posting the pages we create to the SFSU Web space. 

a. Download the course files.

1. A zipped copy of all the files for this course can be downloaded at: ******

2. Once downloaded unzip the file and extract the folder called dreamweaver3 and its contents to your desktop.

b. Define the site.

1. Open Dreamweaver.

2. On the Welcome screen under the Create New section select Dreamweaver Site.

3. Select the Advanced tab (the Basic tab allows you to set the same information but uses a series of questions to help you if you get stuck).

4. Give your site a name – This name will only exist in Dreamweaver. It is used to differentiate between multiple sites you may have defined.

5. Select the folder icon to the far right of Local Root Folder.

6. Navigate to the dreamweaver3 folder you placed on your desktop and select it as your Local Root. (Windows users will need to open the folder before it will be possible to select it.)

7. Use the same steps to set the images folder located inside the dreamweaver3 folder as your default images folder.

8. Leave the ‘Links relative to’ field with the default option of Document – Remember; this is important for the path structure.

9. In the HTTP Address field enter http://userwww.sfsu.edu/~acctname (replace acctname with your email account name).

10. In the Category column select Remote Info.

11. The access type for the SFSU servers is FTP. Go ahead and select this from the drop down menu labeled Access. If you are using another host the access type may be different. You will need to contact your host to determine your access type and any other necessary settings.

12. Enter the following host information:

i. FTP host: apollo.sfsu.edu

ii. Host directory: public_html

iii. Login: your email login (i.e. if your email is janedoe@sfsu.edu your log in name is janedoe).

iv. Password: your email password.

13. Click the Test button to verify that you have entered all the information correctly. You should receive a conformation message stating that Dreamweaver was able to connect – if not, correct your information.

14. Uncheck the box marked Save next to the password field. Unless this box is unchecked Dreamweaver will save your password and, because Dreamweaver does not require a password to log in, it will be available to anyone who accesses the program.

15. Click OK.
III. Creating Hovers
Hovers are an effect that changes the state of a page element when a visitor’s mouse moves over the element. In the Dreamweaver II course we actually added a hover state to our page when we set the ‘Hide underline on rollover’ property while working in the properties panel. If you remember, this caused the standard underline on our links to disappear when the mouse moved over them. If you have previous HTML experience you might equate hovers with rollovers however there is one major difference between the two. Rollovers, because they cause content changes, are often not accessible. Hovers, which change state but not content, are.

At present, the navigation links (the 4 links at the top of the page) do not in any way indicate that they are clickable, they don’t even have the standard underline of a link. Let’s add a hover state so that they change color when a viewer hovers over them.
a. Setup Dreamweaver

i. Open the dreamweaver3_template.html file from the dreamweaver3 folder. (This file was created using techniques from the past two classes.)
ii. Make sure the CSS Panel is expanded and the All button is selected.

b. Add the Hover State.

i. Select the New CSS Rule button from the bottom of the CSS Panel.

ii. In the New CSS Rule window set the Selector Type to Advanced and set the Define in field to styles.css.

iii. The navigation links are located in a Div called menu. Because we want our changes to affect only the links in the menu Div and only their hover state type #menu a:hover in the Selector field (‘a’ is the tag name for links). Note: The :hover state can be applied to any page element, text, images, links, tables, etc.
iv. Click OK.

v. In the Type Category set the Color to #FF9900.

vi. Click OK.

vii. To see the changes, save your work and then preview in a browser.

IV. Creating Font Families
Although it does allow you much greater typography control CSS does not free you from needing to use standard fonts. Since HTML cannot store font information your Web page relies on the end users machine to have the font you specify installed. If it is not available another font is substituted. You do have some control over what font is used as the substitute. If you only specify one font, and the viewer’s machine does not have that font, they will see their browser’s default font. If you specify a list of fonts the browser will go down the list until it finds one that is available.
a. Create a Font Family

i. In the CSS Panel select body,dt,th under styles.css and then click the Edit Style button at the bottom of the panel. By default the Type category should be selected and you should see ‘Areal, Helvetica, sans-serif’ in the Font dropdown.

ii. Click the down arrow at the right end of the Font dropdown and select Edit Font List.

iii. The Edit Font List window contains a list of the existing font families and a list of all the fonts available on your computer. At the bottom of the of the Font list highlight the line that reads (Add fonts in the list below).
iv. Select a font in the Available fonts list.
v. Click the << button to add the font to the Chosen fonts list.

vi. Add two or three more fonts to the list. (NOTE: It is a good idea to choose all of your fonts from the same font category (serif, sans-serif, monospace, fantasy, cursive). Not doing so can have unexpected results.)

vii. There are 5 font categories: serif, sans-serif, monospace, fantasy, cursive. All Web browsers have a default font defined for each category. You must include one of these 5 categories as the last item in your defined font family so that the browser will know what to default to if none of the other fonts are available. You can find the categories at the very bottom of the Available fonts list. Add one of the 5 to your definition.
viii. Click OK.

ix. Select the font you just defined in the Font dropdown.
x. Click OK.

xi. Note the changes to your page. After class today use a computer in one of the other campus computer labs or at home to view your pages – do they display the way you expect them to? Are the fonts you selected installed?
V. Templates
A template is a file used to help build and maintain a Web site. Templates make it easy to consistently update a large site. Templates contain structural information as well as basic code that are standard to all the pages you will be creating. Some examples would be the Div tags for your layout and the link to your CSS file. Once you have a template you can use it to create as many pages as you wish and, if you later need to make a change to your site, you can update the template and the changes will be made in all of the files created with that template.
Templates are also very useful when multiple people will be creating pages for your site. By default all elements in a template are ‘locked’ meaning that they cannot be edited. You specify any regions that you wish to be editable and everything else will remain fixed making it very easy to maintain consistency.
a. Create the Template

i. Save the file dreamweaver_template.html.
ii. From the File menu select Save as Template.

iii. In the Save As Template window make sure that your site name is listed in the Site category and then go ahead and give the template a description. If you wish to change the file name of your template you can do that too.

iv. Click Save.

v. You will be prompted ‘Update Links?’ Click Yes to maintain our path structure as discussed in the Dreamweaver I course.

vi. Note that the tab for this document, at the top of the Document Window, now displays the file as having a .dwt (Dreamweaver Template) file extension.
b. Add editable regions. 

i. On the Document Toolbar click the Visual Aids button and make sure the Invisible Elements option is checked (otherwise you won’t be able to see what you are doing).

ii. Select the text that reads ‘This is Where the Header Will Go’.

iii. From the Insert menu select Template Objects > Editable Region.

iv. Give the region a name and click OK. A box with a tab containing your title should appear around the selected text. 
v. In turn, select the four lines that read ‘Content’ and the four navigation links and make them editable regions so that you have a total of three editable regions on your page.

vi. Save your file – you will see a warning that you have placed your editable regions inside areas that are not editable. This is what we were expecting so click OK.
c. Create a New Document from a Template

i. Select File > New.

ii. Select the Page from Template Category.
iii. Make sure your site is the one that is selected and then select the template you just saved.

iv. Make sure the Update page when template changes check box is checked.

v. Click Create.

vi. Save the page in your root folder as index.html.

vii. Move your mouse around the page. Notice how, outside of the three boxes, your mouse won’t let you click anywhere but that it changes to a cursor when inside any of the three boxes. There is also a yellow box in the top, right corner letting us know what template this page is based on.
viii. Create a second page from the template. Save it as dreamweaver3.html.

ix. In the dreamweaver3.html document change the navigation links to read: Home, Dreamweaver I, Dreamweaver II and Accessibility. As you change each one use the Link field in the Properties Palette to change the associated Link to the correct page.
x. Using the File panel expand the folder called assets and double click on the file contents.txt to open it. This file contains all the text for the index and dreamweaver3 pages.

xi. Copy and paste the appropriate header and content text into both pages.

xii. Save your work.

d. Update a Template

We have now created all the pages for our site, but imagine that the decision has been made to change the header image… do we have to change it on every page? No, we will change it once using the template and Dreamweaver will do all the maintenance work for us.

i. Using the File Panel expand the folder called Templates and double click on your template.

ii. Select the header image.

iii. Click the browse (folder) icon next to the Src field in the Properties Palette. This should automatically open your images folder.

iv. Select the file banner_green.jpg and click OK.

v. Save your template – You will see the warning about editable regions again, click OK.

vi. Dreamweaver will ask if you wish to update all the files based on the template. Click Update.

vii. Click Close when the update completes.

viii. Preview your pages in a browser. Notice that the header image on the index and dreamweaver3 pages is now yellow and green while the other pages, those not created with the template, still have the orange and red header.
VI. Anchors
As you browse through the web pages notice how just below the first paragraph on each page there is a set of links. Clicking on one of these links does not take you to a new page but instead moves you to a different area on the same page. These links point to what is called an anchor.
a. Create the Anchors

i. In Dreamweaver, go ahead and close all documents except dreamweaver3.html.

ii. In dreamweaver3.html highlight each of the subheadings (Hovers, Font Families, Templates, Anchors, Accessibility and Optimization) in turn and use the Properties Palette to set them as Format Heading 2.
iii. Place your cursor just before the H in the word Hovers of the first subheading.

iv. Select the Common tab/dropdown on the Insert bar.

v. Click the Named Anchor button.

vi. In the Anchor name field enter a name. The name must be unique, it should contain no spaces and you want it to be something you will associate with this heading. (Example: you could use the word ‘hovers’ for this anchor and ‘font’ for the one below it.)
vii. Click OK. You should see a small anchor symbol appear next to your subheading.

viii. Add an anchor point to each of the five remaining subheadings giving each a unique name.
b. Create Links to the Anchors

i. Just below the first paragraph is a list of all of the subheadings. Highlight the word Hovers in this list.

ii. Click the Hyperlink button on the Insert Palette.

iii. Click the dropdown arrow in the Link field.

iv. Select the name you gave the anchor next to the Hovers subheading (it will have a # symbol in front of it denoting it as an anchor).

v. Add a title for the link.

vi. Click OK.

vii. Create the links to the remaining five anchors.

viii. Save your work.

VII. Going Live

Time to post it to the Web.

a. In the Files panel group click the Expand to show local and remote sites button from the buttons along the top of the panel.

b. The window that opens will display your local files on the Right and, once connected, the files on your server to the Left. Click the Connect button (the blue ‘plug’ icon) and enter your password when prompted.
c. Right click in the blank area on the Remote Site side of the window.

d. Select New Folder.

e. Rename the folder dreamweaver.

f. Click the dropdown box titled Show and select Manage Sites.

g. Select your site and click Edit.

h. Change the Category to Remote Info and change the Host directory to public_html/dreamweaver.

i. Select OK and Done.

j. If necessary click the Connect button again and enter your password when prompted.

k. Highlight your site folder on the Local Files side of the window.

l. Click the blue Put Files arrow.

m. You will be prompted ‘Are you sure you wish to put the entire site?’ Select OK. (Note: In general you would want to upload only those pages you have made changes too but because we have not posted any of this site previously we will put the entire site.  This is a warning because uploading a whole site can take a lot of time if the site is big!)

n. Open a Web browser and go to http://userwww.sfsu.edu/~acctname/dreamweaver (where acctname is your account name).

VIII. Accessibility
Hopefully you have noted throughout the three Dreamweaver courses that there has been an emphasis on adding accessible content wherever possible. There is a big push in the online community right now to make content accessible. This is occurring partially because users are demanding it but also because the Federal Government passed accessibility legislation mandating that commercial and government Websites must be accessible for disabled users. Not to mention that more and more users are accessing the Web via mobile devices and accessible content greatly enhances the use of those mediums too. 
Go ahead and navigate to the Accessibility link on the Website you just posted. It contains some good information on accessibility you can reference as the subject is discussed…
What is Web Accessibility?

In simple terms Web accessibility means that someone with a disability can use the Web. Although this may seem like a simple goal it becomes more complex when you define the word ‘use’. To use the Web a visitor must be able to perceive, understand, navigate, interact and contribute (where appropriate) to the Web. The disabilities that must be considered when designing for the Web encompass visual, auditory, physical, speech, cognitive and neurological issues. If you would like to learn more about how each of these disabilities affect Web use check out the document (http://www.w3.org/WAI/EO/Drafts/PWD-Use-Web/#diff ) created by the folks of the World Wide Web Consortium. 
Here at SFSU the campus community is actively working to update the university Web system. We have added compliance requirements mandated by the CSU and its policies and in 2006 the university launched its own Accessible Technology Initiative… Although much of what has and is happening is behind the scenes you should shortly begin to see some dramatic changes to the university’s Web sites. You can check out one of the first new sites to be posted at http://www.sfsu.edu/~news 

The good news is that designing to facilitate accessibility is also generally beneficial to your site.
Connecting the Components
In order for a Web site to be accessible a number of components must have the ability to function together as seamlessly as possible. These include site content and presentation, the Web browser or media player in which the content is being viewed, any assistive technology such as a screen reader or alternative keyboard, the users knowledge for using the Web and the designers knowledge for creating, the tools used to create content and the tools used to evaluate the product. By following a design standard the interaction between these components should be relatively straight forward. As an example, take a look at the list below (provided by www.w3.org) that mentions how each component facilitates the accessibility of an image through the process of adding an alt tag (alternative text):

· Technical specifications address alternative text (for example, HTML defines the alternative text attribute (alt) of the image element (img))

· WAI guidelines - WCAG, ATAG, and UAAG - define how to implement alternative text for accessibility in the different components

· Developers provide the appropriate alternative text wording

· Authoring tools enable, facilitate, and promote providing alternative text in a Web page

· Evaluation tools are used to help check that alternative text exists

· User agents provide human and machine interface to the alternative text

· Assistive technologies provide human interface to the alternative text in various modalities

· Users know how to get the alternative text from their user agent and/or assistive technology as needed

Guidelines

There are guidelines for most of the components that are involved in creating Web sites including content, browser and development applications. As a designer there are 14 guidelines you will primarily be concerned with:

1. Provide equivalent alternatives to auditory and visual content.

2. Don't rely on color alone.

3. Use markup and style sheets and do so properly.

4. Clarify natural language usage

5. Create tables that transform gracefully.

6. Ensure that pages featuring new technologies transform gracefully.

7. Ensure user control of time-sensitive content changes.

8. Ensure direct accessibility of embedded user interfaces.

9. Design for device-independence.

10. Use interim solutions.

11. Use W3C technologies and guidelines.

12. Provide context and orientation information.

13. Provide clear navigation mechanisms.

14. Ensure that documents are clear and simple.
Further information on each of these guidelines can be found at http://www.w3.org/TR/WCAG10/
SFSU has an additional six guidelines for official pages posted to the university’s web space:

1. Create meaningful page titles.

2. Use meaningful text for links.

3. Inform the user about pop-ups or new windows.

4. Create accessible PDF files.

5. Create structured content.

6. Validate your HTML.

More information on SFSU specific compliance can be obtained from the Web Team (webteam@sfsu.edu). 
Evaluating Site Accessibility

Website evaluation is a topic to large to be covered extensively in this course. For specific information you can visit www.w3.org. SFSU has a defined procedure for assessing Web pages and further information can be obtained by contacting the Web Team (webteam@sfsu.edu). 

For those of you just beginning to assess your pages here are some quick tips for getting started:
· Make sure you have the most up to date versions of Firefox and Internet Explorer.

· Install accessibility toolbars – Firefox Accessibility Extension: https://addons.mozilla.org/en-US-firefox/addon/5809 Firefox Web Developer: https://addons.mozilla.org/en-US/firefox/addon/1891 Internet Explorer Web Accessibility: http://www.visionaustralia.org.au/info.aspx?page=1569
· Verify that your site does not flicker at http://ncam.wgbh.org/richmedia/media/flicker_demo.html
· Try navigation your site with the demo version of the screen reader JAWS http://www.freedomscientific.com/fs_downloads/jaws.asp
· Review the CSU 508 checklist at http://www.calstate.edu/Accessibility/webaccessibility/evaluation/index.shtml
· Web Aim – www.webaim.org
· Validate your page at http://cynthiasays.com
IX. Optimizing for Search Engines
Search engines are the primary starting point for Internet users seeking content. Almost 90% of Internet traffic originates from a search engine making it important to get your website listed with a major portal if you wish to bring traffic to your site. Back in the early days of the Web, sites used Meta tags to let engines know what content was on their page. Although still in use this system is no longer a predominant method for categorizing pages as the potential for abuse is high. Larry Page and Sergey Brin, who went on to found the company Google, developed a method known as a ‘backrub’ engine that is the more common method used today. These engines use mathematical formulas and look at a number of different page elements including: Meta tags, body text, image alt tags, image names and URL names. Here are some key points to remember when optimizing:
· Determine appropriate key phrases to use on your page.

· Multi-word key phrases are generally more likely to be listed in search results because competition for single word phrases is high.

· Position your key phrases not only in your Meta tags but in your text close to the beginning of your document – they will be assigned more importance this way.

· Search engines do not always ‘crawl’ through all the levels of a site. Place relevant search information in the first or second layer of pages.

a. Add Meta Tags to Your Web Site
i. Using the File Panel expand the Templates folder and double click on your template to reopen it.
ii. Select from the Insert menu HTML > Head Tags > Description.

iii. Enter a meaningful description of the page and click OK.

iv. Select from the Insert menu HTML > Head Tags > Keywords.

v. Enter keywords or short phrases separated by commas and click OK.

vi. Save your template – You will see the warning about editable regions again, click OK.

vii. Dreamweaver will ask if you wish to update all the files based on the template. Click Update and, when Dreamweaver finishes, click Close.
X. Post Your Changes
a. In the Files panel group click the Expand to show local and remote sites button from the buttons along the top of the panel.

b. If necessary click the Connect button (the blue ‘plug’ icon) and enter your password when prompted to reconnect. 

c. Highlight your index.html file on the Local side of the window.

d. Click the blue Put arrow. 

e. Highlight your dreamweaver3.html file on the Local side of the window.

f. Click the blue Put arrow. 
CHALLENGE: Recreate the Dreamweaver I, Dreamweaver II and Accessibility pages using your template – you can copy the data from the existing pages. When finished upload them to the Web.
XI. Q & A
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