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I. Introduction
a. What is it?

Dreamweaver is a Web development application. The program is graphic based so it is possible for non-programmers to create Web pages and small Web applications. Dreamweaver version 9.0 is included with the applicable Adobe CS3 bundles.

II. Important Terms
a. What are HTML and XHTML?

HTML (Hypertext Markup Language) and XHTML (Extensible Hypertext Markup Language) are the predominant languages for creating Web pages. They provide a means to describe the structure of text-based information in a document. HTML and XHTML are written in the form of tags, surrounded by angle brackets. The two languages are almost identical. XHTML is a ‘cleaned-up’ version of HTML and places stricter restrictions on the way the code is written to enhance its compatibility with multiple devices (i.e. phones) and screen reading software.  Dreamweaver creates XHTML code by default.

1. Further information on Web languages and standards can be found at www.w3.org, the home of the World Wide Web Consortium (W3C). W3C is the developer of Web standards. 

b. What is CSS?

Cascading Style Sheets (CSS) are a method for controlling the appearance of a page or, more commonly, multiple pages on a Web site. A style sheet allows a developer to create a single, common list of styles that can be easily referenced by a page rather than requiring that each style be defined on each individual page. In effect this concept separates content from style and allows for much greater ease when making changes to an entire site. Dreamweaver CS3 has improved and added many tools for easy creation and integration of CSS. 

1. To see CSS in action try visiting the site http://www.csszengarden.com.

c. Index.html
For the most part you can name a Web page anything you want as long as it follows standard naming conventions (i.e. does not contain spaces and ends in .htm or .html). The exception to this is the index.html page (Some Web hosts use different default page names. Although index.html is generally standard your host may also use index.htm, welcome.html or welcome.htm. You will need to obtain information on which is correct for your host from your host service.) Index.html is the default page of the folder you are working in. When located in the root or main folder of your web space it becomes your default or main Web page.

i. Open a Web browser and go to www.yahoo.com by typing the address in the Address bar.

ii. Now type www.yahoo.com/index.html in the Address bar. Notice how the same page comes up.

III. A Couple of Warnings

a. WYSIWYG
Because of its graphic interface Dreamweaver is often referred to as a WYSIWYG (What You See Is What You Get) design program. However, it is important to note that is a somewhat misleading statement. Each Web browser, Internet Explorer (IE), Firefox, Safari, Opera, etc. has its own way of rendering information. Something that is designed for Firefox may not appear correct in IE or vice versa. It is always best to design for multiple browsers by checking your page using multiple browsers and/or Web design tools such as the Firefox designer tool bar.

b. HTML

Although Dreamweaver is a graphics based design software using it for all your development does have several shortcomings. For example, it can sometimes be difficult to manipulate tables, layout elements, etc. through the graphic interface. It is therefore recommended that you learn some basic HTML programming so you can resolve these limitations by working directly with the code.

IV. Dreamweaver Interface

a. The Welcome Screen

The Dreamweaver Welcome screen provides shortcuts to actions you may wish to ‘jump’ to when launching the program. You can open a recent file or click on the open button to open older files. You can create a new page or new site or you can select an Adobe template to use as a foundation for a design. For now create a new blank HTML (this is actually XHTML) page so we can review some of the interface components.

1. Launch Dreamweaver.

2. Select HTML from the Create New column on the Welcome Screen.

3. Select Window > Workspace Layout > Designer(Win)/Default(Mac)  to make sure you have the standard set of palettes open.

b. Insert Bar

The Insert Bar, located above the main document window, contains several series of buttons. Each button will add a standard element such as a link or table to your web page. The buttons are grouped together into task groups: Common, Layout, Forms, Data, Spry, Text and Favorites. The palette can be displayed ether in tabbed mode or as a drop down menu to save screen real estate. The favorites tab is customizable – allowing you to create a tab that has all of the elements you use most.

1. Select the Favorites tab or the Favorites item from the drop down menu.

2. Right click on the on the Insert Bar and select Customize Favorites from the pop-up menu.

3. Add Hyperlink, Email Link, Image and Horizontal Rule to your Favorites.

4. Add a separator and change the order if you wish.

5. Click OK. 

c. Property Inspector / Properties Palette

The Property Inspector palette, located below the main document window, displays the properties for the current element you are working with. Because we have a blank page open Dreamweaver assumes we are going to be working with text and is therefore displaying text properties in the Property Inspector. It is generally a good idea to keep this palette open when you are working as many of the properties found here are not available through any of the other Dreamweaver menus. If you accidentally close this (or any other) palette you can reopen it from the Window menu.

1. Close the Property Inspector – Windows: Click the Menu icon in the top right corner of the palette and select Close Panel Group, Mac: Click the small circle located on the left of the palette.

2. Re-open the Property Inspector by selecting Window > Properties.

d. Document Toolbar

The Document Toolbar, a part of the main document window, is located at the top of the main design area. It contains options for setting your viewing preferences, adding a title to your page and previewing and validating your code.

1. Viewing Preferences

As a designer you will probably spend most of your time with the Design view open. However, there may be times when you wish to work with the code directly. There are two methods to do this: Code view which displays the code in the document window and Split view which displays the code and design views simultaneously.

i. Select Split view. Note how Dreamweaver has already created several lines of essential code for us even though we have not added any content to the page.

2. Title

The Title box is where you can set the title for the page. The title will appear at the top of the Web browser when the page is viewed and will be used as the default bookmark name for the page.

i. Type your name in the title box. 

ii. Click anywhere inside the code view window. Notice how the content between the title tags has been automatically updated.

3. Viewing and Validation

The 7 buttons to the right of the Title box are used for uploading files to the Web, viewing and previewing your page and validating the page code. We will be using several of them throughout these tutorials.
e. Document Window

The document window is where you will do the majority of your design work but it also contains several key elements for navigating your pages and designs. 

1. Tabs

Each page you have open in Dreamweaver will be displayed as a tab across the top of the document window making it easy to switch between multiple pages. Each tab will be marked with the name of the file you are working on. Be careful not to confuse the file name with the page title. When you make changes to the page an asterisk will appear next to the file name on the tab. This lets you know that the changes you have made have not yet been saved and the asterisk will disappear when the page is saved.

2. Tags

Currently the only tag listed in the tags section along the bottom of the document window is the <body> tag. However, as you build your page you will see a number of tags appear in this section. The tag selectors are a shortcut method of selecting elements on your page and can be very helpful when you are trying to select items that may be hard to click on i.e. the border of a table.

3. Size Properties

The size elements in the lower right of the window have several purposes. The zoom tool acts much like the zoom in any graphics program and is used when you want a closer look at what you are working on. The view size area displays the page you are designing at various standard monitor sizes so that you can get a feel for what your page will look like on a smaller or bigger monitor. The page size/download time area lets you know how big your file is and how long the page will take to download. By default the time shown is for a 56k modem.

f. Panels

Panel groups are sets of related panels grouped together under one heading. Each panel contains additional functions or administration options. One of the options within in the panels groups is the Files panel. The Files panel enables you to manage your files and folders, whether they are part of a Dreamweaver site or on a remote server. The Files panel also enables you to access all the files on your local disk, much like Windows Explorer (Windows) or the Finder (Macintosh).
1. To expand a panel group, click the expander arrow at the left of the group's name. 
2. To undock a panel group, drag the gripper at the left edge of the group's title bar.
3. Set up your panels so you can see the Files panel.
V. Define a New Site
a. File Management

A website consists of a series of pages, images and other elements linked together. The paths between elements are important and it is a good idea to create a set of files on your computer that mimic the file structure of your web space. By doing this Dreamweaver will be able to correctly create and maintain links in your documents and these links will not need editing when you post your pages to the internet. Although it is possible to edit information placed in the files on your computer using a program other than Dreamweaver it is recommended that once you have defined a site you access your site files only from within Dreamweaver so that the program can maintain structural information for you.

1. Minimize Dreamweaver so that you can see the desktop of your computer.

2. Create a new folder on the desktop and label it with your name.

3. Create a second folder inside the first folder and name it public_html (public_html is the default directory for Web data on the SFSU servers. If you will be publishing your pages through a different host this folder may have a different name).

4. Inside your public_html folder create a third folder called images.

5. Maximize Dreamweaver again.

b. Define a Site

The folder public_html that we created in the last section is known as your site folder or local root folder. As we create our site we will be adding all of the elements we will be posting to the Web into the site folder. Dreamweaver needs to know where this folder is located in order to perform its file management functions. Letting Dreamweaver know where this folder is located is known as defining a site.

1. Select Site > New Site.

2. Select the Advanced tab (the Basic tab allows you to set the same information but uses a series of questions to help you if you get stuck).

3. Give your site a name – This name will only exist in Dreamweaver. It is used to differentiate between multiple sites you may have defined.

4. Select the folder icon to the far right of Local Root Folder.

5. Navigate to the public_html folder you just created and select it as your Local Root. (Windows users will need to open the folder before it will be possible to select it.)

6. Use the same steps to set the images folder you created inside your public_html folder as your default images folder.

7. Leave the ‘Links relative to’ field with the default option of Document - This is important for the path structure which we will discuss as we add images to the page.

8. Click OK – The remaining options would allow us to connect the site to the Web space where the pages will be posted. We will be doing this in the next class.

9. You should now see your folders in the Files palette.

VI. Create a Web Page

a. Create a New Page
1. Select File > New.

2. Select Blank Page.

3. Select HTML.

4. From the DocType drop down box select XHTML Strict – This will make the code we create comply completely with XHTML standards. The other options would allow us to use a mix of HTML and XHTML.

5. Select Create. 
b. Saving
Once you create a page the first thing you should do is save it, even if it is still blank, so that Dreamweaver knows where it will reside in your site.

1. Select File > Save - Dreamweaver should automatically open your site folder if not, navigate to it.

2. Rename the file to index.html (this will be our default site page).

3. Select Save. You should see the file appear in the Files palette under your main site folder.
c. Page Properties

The Page Properties window allows you to set default properties for some of the basic elements on your page. Although most of these elements can be edited elsewhere or typed directly into the code this is the best place to find them grouped together for easy access.

1. Select Modify > Page Properties.

2. Font

The Page Font property sets the font for your page. By default the selected option is ‘Default Font’. The default font will display whatever font the viewer has set as the default for their Web browser. The other options available are not individual fonts but font families. Because computers do not all have the same fonts installed the browser will display the installed font for that font family on the viewers machine.

3. Font Size

Some care needs to be taken when selecting a font size. You will notice that there are some ‘unusual’ sizes listed along with the standard 8, 10 12, etc. pixel fonts. By using a set size you will be able to set the exact size of any type that appears on your page… but you may potentially cause an issue for someone with vision problems. By selecting a size such as large or small your Web page will be displayed at the size the viewer has set as their default with the large or small option adding or subtracting from their default font size leading to increased readability.

4. Color Options

There are several different items you can set default colors for - background, text and links. Again, care must be taken when selecting colors in order to make sure the elements on your page are viewable. You need to maintain good contrast for visibility purposes. It is also important, for consistency, to select Web safe colors. Although most computer monitors can display millions of colors there are only 256 that are standard and guaranteed to be render-able by a Web browser.

5. Title/Encoding

Changing the title of your page through the Page Properties is the same as changing it in the Document Toolbar. You can also change the Document Type if you selected the incorrect type during page setup.

6. After you have made any desired changes to your page select OK.

VII. Add Page Elements

a. Text
Working with text on a Web page is similar to working with text in a word processing program. The text will appear as plain, unformatted text until markup (i.e. formatting) is applied. The standard types of markup/formatting in Dreamweaver are headings, paragraphs and lists. To each of these formats different styles can be applied such as bold/strong, italics, block quotes, colors, etc.

1. If Code or Split view is still open change back to Design view.

2. Type a heading for your page in the document window.

3. Change the Insert palette to the Text functions.

4. Highlight your heading and change the style to H1 (Heading 1) and italicized.

5. Try adding a bold/strong style to your heading. Did anything change?

6. Notice, in the Properties Palette, that Dreamweaver has correctly set the text as type Heading 1. Because Heading 1 is already set as bold adding bold again didn’t visibly change anything.

7. Use the Properties palette to center your heading. 
b. Horizontal Rule

It is often a good idea to break a Web page up into different visual areas. A common way of doing this is by adding a horizontal rule to a page.

1. Change the Insert palette to the Favorites functions.

2. Make sure your cursor is at the end of your text.

3. Click the Horizontal Rule Button on the Insert Palette.

4. In the Properties palette use the width and height options to format your Horizontal Rule. Try using both the pixel and percent options when setting the width. Note the difference.

c. Images
All content you will be adding to your site must be stored in your local root folder. If your content is located elsewhere it will need to be copied or moved to the correct location.

1. Use the dropdown box at the top of the Files palette to navigate to the Desktop > Course Folder > Dreamweaver I folder.

2. In this folder there is a file titled colors.jpg. Right click on the file and select Edit > Copy.

3. Use the dropdown box to navigate back to your site folder.

4. Right click on the images folder you created earlier and select Edit > Paste. The colors.jpg file should now be visible in your images folder.

5. In the document window place your cursor on a new line below your Horizontal Rule.

6. On the Insert palette under Favorites select Image. This will open the Select Image Source dialogue box.

7. Select the colors.jpg image from your images folder and select OK.

8. A second dialog box titled Image Tag Accessibility Attributes will appear. This box gives us the ability to add alternative text that will be used any time the image cannot be displayed i.e. when a viewer is using a cell phone or screen reading software. Add a description and click OK.

d. Path Structure

It is important to note that the image added in the previous steps is not actually located on your Web page. Instead Dreamweaver has inserted a path to the file and is displaying what the path points too. If we were to make a change to the colors.jpg image using another program and resave the image the image visible in Dreamweaver would display the changes. Maintaining these paths is part of why you should do your file management from within Dreamweaver. If, outside of Dreamweaver, you were to move or rename your image file the path would not update and you would see a ‘broken’ image icon on your Web page. 

There are two types of paths that can be included in a Web page – Relative and Absolute. Relative paths point to information using the current page as their reference point. Absolute paths require that the full Web address of a page or asset be included. Relative paths are good when you know that the file structure of your page and assets will remain the same. They may be used only with pages and assets located within your site. Absolute paths on the other hand are great for linking to items whose location on the Web will not change even if the location of your file does. Absolute paths are required when pointing to information outside of your Web site.

If you examine the Properties palette with the image selected you will see that the field labeled Src (short for Source) lists images/colors.jpg. This is a relative path – the images folder must be located in the same folder as the page we are working on. If you examine the File palette you will note this is true. We will take a closer look at both of types of paths as we add links to the page.

e. Links
Links are case sensitive and must be exact in order to function correctly. It should also be noted that some browsers do not handle spaces in file or asset names well. For example a browser would interpret a link to a file called color.jpg and a link to a file called Color.jpg to be two separate files. If these files were located in a folder called ‘my images’ the browser may or may not be able to see them at all. For these reasons it is generally standard to give Web pages and other assets including folders names that are all lowercase and do not contain spaces.

1. Links using Absolute Paths

i. Add a new line to your page and type the name Yahoo!.

ii. Highlight the text and click the Hyperlink button from the Favorites section of the Insert Palette.

iii. In the field labeled Link type http://www.yahoo.com (make sure to include the http:// ).

iv. Add a Title  - This title will appear as a tool tip in most browsers and give additional information to someone trying to access the link while using a screen reader.

v. Click OK.

2. Links using Relative Paths

In order to create a relative path we first need to have something to link to…

i. In the Files Palette right click on your root folder and select New File. This will create a new html file under your site folder.

ii. Rename the page to contact.html.

iii. Open the new page by double clicking on the file in the Files palette.

iv. Type your name and email address on the new page.

v. Select the tab for your index page at the top of the document window to switch back to the index page.

vi. Add a new line and type Contact.

vii. Highlight the text and click the Hyperlink button on the Insert Palette.

viii. Click the folder button next to the Link field.

ix. Select the contact.html file from your root folder.

x. Add a title and click OK.

3. Email Links

i. Select the tab for your contact page at the top of the document window to switch back to the contact page.

ii. Highlight your email address.

iii. Click the Email Link button on the Insert palette.

iv. Dreamweaver will recognize that this is already in the correct format. Change the text if you would like it to read something else.

v. Click OK.

VIII. Preview Your Work

a. Now that we have added elements to our Web pages it is time to see what they look like in a browser. Remember that they may appear differently in different browsers.
1. Save your files by selecting File > Save All.

2. Click the Preview/Debug in Browser button on the Document toolbar.

3. Select one of the listed browsers.

4. Try your links…

CHALLENGE:  Try to format your contacts.html page so that it looks like your index.html page.
IX. Q & A

a. Next Week: Tables, Layout (beginning CSS), Publishing to the Web.

Two Weeks: Templates, Rollovers and other neat tricks, Publishing, Accessibility.
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