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1. Microsoft Access 2007 – Overview

a. What is it?

Access 2007 is the latest database development application from Microsoft. It is one of the many software programs that make up MS Office 2007 which is available only for the Windows PC operating system.  It is used to create and manage lists, query data, and provide reports. Access data can be read directly into the other Office 2007 programs for mailing lists and to create graphs.
2. Open an Existing Database

a. From the Office Button > Open > Desktop > Course Files > Access III > students.accdb
b. Be sure to click the Options button on the security warning and enable this content
3. Create a new table
a. From the Ribbon > Create tab > Tables Group > Table. 
b. From the Ribbon > Tables Tools > Datasheet tab > Views group > View section > click Design View. 
i. In the Save As popup name the table College List.
4. AutoNumber data type

a. What is this?
You can set the Data Type to the AutoNumber, which automatically numbers each record created.
b. Edit first field: ID
i. Rename Field : CID

ii. Date Type: AutoNumber
iii. Field Properties:

1. Field Size: Long Integer
2. New Values: Increment
3. Caption: College ID#
4. Required: Yes (No Duplicates)

5. Text Alignment: General
5. Create fields for additional information
a. Field Name: cname

i. Date Type: Text
ii. Field Properties:

1. Field Size: 25
2. Caption: College Name
3. Required: Yes 
4. Allow zero lenth: No
5. Indexed: No
b. Field Name: dean

i. Date Type: Text
ii. Field Properties:

1. Field Size: 25
2. Caption: Dean
3. Required: No
4. Allow zero length: Yes
5. Indexed: No
c. Field Name: pnum
Note: when asked to save the table, say yes
i. Date Type: Text
ii. Field Properties:

1. Field Size: 10
2. Input  Mask: to format, use the “…” button to select the phone number input mask, click Finish
3. Caption: Phone Number
4. Required: No 
5. Allow zero length: Yes
6. Indexed: No
6. Enter Data

a. From the Ribbon > Tables Tools > Design tab > Views group > View section > click Data Sheet View. 

i. First record enter:
7. College Name: Humanities
8. Dean: Mickey Mouse
9. Phone Number: (415)338-1111
ii. Second record enter:

1. College Name: Business
2. Dean: Donald Duck
3. Phone Number: (415)338-2222
iii. Third record enter:

1. College Name: Science
2. Dean: Shaggy Dog
3. Phone Number: (415)338-3333
iv. Fourth record enter:

1. College Name: Creative Arts
2. Dean: Herman Munster
3. Phone Number: (415)338-4444
v. Fifth record enter:

1. College Name: Education
2. Dean: J Edgar Hoover
3. Phone Number: (415)338-5555
vi. Sixth record enter: 
1. College Name: Ethnic Studies
2. Dean: B B King
3. Phone Number: (415)338-6666
vii. Seventh record enter: 
1. College Name: HSS
2. Dean: 
Wile Coyote
3. Phone Number: (415)338-7777
viii. Eighth record enter: 
1. College Name: BSS
2. Dean: Bozo D’Clown
3. Phone Number: (415)338-8888
ix. Ninth record enter: 
1. College Name: Other 
2. Dean: None
3. Phone Number: None
b. Close the table
7. Creating a field linked to another table
a. Open the students table in the design view

b. Select Field named faid
c. From the Tools menu click Insert Rows

d. This will create a new blank field line

e. Add a new field

i. Field name college 
ii. Date Type: Lookup Wizard
iii. Select the radio button for “I want the lookup column to look up values in a table or query”.

iv. Click Next
v. Select Table: College List 
vi. Click Next
vii. Add CID and cname to the Selected Fields
viii. Click Next
ix. In the sort order box select cname
x. Click Next
xi. Click Finish
xii. Save your table design
xiii. Save the new relationship
8. Create a limited data Form

a. From the Ribbon> Create tab > Forms group > from the  More 
Forms Menu > select the Form Wizard
b. Select Table: Students in Tabels/Queries
c. Select 
sid in Available Fields: and click the > button to add it to the Selected Fields: list
d. Select  college in Available Fields: and click the > button to add it to the Selected Fields: list
e. Click Next
f. Select the Columnar radio button for the form layout

g. Click Next

h. Select a style from the list

i. Click Next

j. Enter College Updater as the forms title

k. Make sure the Open… radio button is selected
l. Click Finished
9. Edit a records with a form
a. Using the College Updater form add the following information to the 9 existing records.
	Student ID #
	College

	111-11-1111
	HHS

	222-22-2222
	BSS

	333-33-3333
	Other

	444-44-4444
	Education

	555-55-5555
	Science

	666-66-6666
	Business

	777-77-7777
	BSS

	888-88-8888
	HSS

	999-99-9999
	Other


10. Importing data
a. What is it?

Access provides a method for importing external data into an access database. The date may be imported from a wide range of sources
b. Importing data from an Excel table
i. On the Ribbon, in the External Data tab > in the Import group > select Excel
1. From the Get External Data wizard make sure that the radio button in front of Import the source data into a new table in the current database is selected 
2. In the  File name: window use the Browse button and navigate to the Desktop > Course Folder > Access III > GRE.xlsx
3. Click the Open button
4. Click the OK button in the Get External Data wizard
5. The next page will display the data as it was imported from excel allowing you to select the page you wish the data from. 
6. Click the Next >  button in the Import Spreadsheet wizard
7. If the headings on the imported sheet contain labels rather than data, make sure the First Row Contains Column Headings box is checked. 
8. Click the Next >  button in the Import Spreadsheet wizard
9. In this window specify field name and the type of data in each column. In our example SSN should be text and Score should be an integer.
10. Click the Next >  button in the Import Spreadsheet wizard
11. Make sure the radio button on Let Access add primary key is selected
12. Click the Next >  button in the Import Spreadsheet wizard
13. Name the table GRE Data in the Import to table: window
14. Click the Finish button in the Import Spreadsheet window
15. Use the Options button to enable this content
11. Creating Relationships
a. What is it?

1. You can create a table relationship in the Relationships window, or by dragging a field on to a datasheet from the Field List pane. When you create a relationship between tables, the common fields are not required to have the same names, although it is often the case that they do. Rather, the common fields must have the same data type. If the primary key field is an AutoNumber field, however, the foreign key field can also be a Number field if the Field Size property of both fields is the same. For example, you can match an AutoNumber field and a Number field if the Field Size property of both fields is Long Integer. When both common fields are Number fields, they must have the same Field Size property setting.

b. Creating a relationship between the importing data from an Excel table in the GRE Data table and the Students table
i. On the Ribbon, in the Database Tools tab > in the Show/Hide group > select Relationships
1. In the relationship tab you will see your two currently linked tables  College list and Students
2. On the Ribbon, in the Database Tools,  Design tab > in the Relationships group > select Show Tables
3. Select the GRE Data table from the list
4. Click the Add button 
5. Click the Close button 
6. The Relationships tab should now show College List, students, and GRE data
7. Close the Relationships tab and save changes
12. Creating a Query with data from multiple tables 
a. What are they?

A method for selecting, sorting and manipulating data extracted from one or more tables or queries. 
b. Creating a query with sorting
i. On the Ribbon, in the Create tab > in the Other group > select Query Design
1. From the Show Table window in the Tables tab select the tables Students, College List and GRE Data
2. Click Add at the bottom of the window
3. Click Close at the bottom of the window after adding the three tables
a. The top section of the screen will now display the field lists from the  tables or queries that will be used  in this query

b. The lower section displays the Design Grid 

4. Specifying fields Click the Field:  > down arrow to display the list of fields available
a. Select sid from Students for the first field (always include your master key in queries so that they may be used as part of future queries)

b. Select fname from Students for the second field
c. Select lname from Students for the third field
d. Select cname from College List for the fourth field, this is due to the fact that College from Students contains only the numeric master key linking all of the College List data to the Students table

e. Select score from GRE Data for the last field
5. Use the Sort row to select the cell under college, click Sort: > down arrow and select ascending
6. Run the query and create a results table 

a. On the Ribbon, in the Design tab > in the Results group > select Run
b. To save the results click the save icon on the Quick Tools bar and rename the file to College Sort
c. Creating a query with a calculated value

ii. On the Ribbon, in the Create tab > in the Other group > select Query Design
1. From the Show Table window in the Tables tab select the students 
a. Click Add at the bottom of the window
b. Click Close at the bottom of the window

2. Specifying fields

a. Click the Field:  > down arrow to display the list of fields available

b. Select sid for the first field (always include your master key in queries so that they may be used as part of future queries)

c. Select the next blank field
d. On the Ribbon, in the Design tab > in the Query Setup group > select Builder to open the Expression Builder

i. Expand Tables
ii. Select students
iii. Double click qpoints
iv. Press the / button
v. Double click chours
vi. Click Ok
vii. Press Enter

viii. You should now see Expr1: [students]![qpoints]/[students]![chours] on the field line

ix. Select the Expr1 portion of the expression and change it to GPA

e. Display the properties, on the Ribbon, in the Design tab > in the Show/Hide group > select Property Sheet – if it is not already active
f. In the Property Sheet pane under Format selected Fixed 
2. Run the query and create a results table 

a. On the Ribbon, in the Design tab > in the Results group > select Run
b. To save the results click the save icon on the Quick Tools bar and rename the file to GPA
d. Creating a query combining information from multiple sources

i. On the Ribbon, in the Create tab > in the Other group > select Query Design
1. From the Show Table window in the Both tab select students, and GPA 
2. Click Add at the bottom of the window
3. Click Close at the bottom of the window when you are done
4. Specifying fields Click the Field:  > down arrow to display the list of fields available

a. Select students.sid for the first field 
b. Next student.college and sort: descending
c. Next gpa.gpa and sort: descending
d. Next student.fname 

e. Next student.lname 

5. Run the query and create a results table 

a. On the Ribbon, in the Design tab > in the Results group > select Run
b. To save the results click the save icon on the Quick Tools bar and rename the file to Class Rank
13. Challenge

a. Create a query that contains GPA, GRE scores and College Names

b. Using your new Query generate a report grouping GPA and GRE scores by college
14.   Open floor for Challenge discussion and Questions
15.  Appendix A: Data types available in Office Access 2007
The following table describes the data types available for fields in Office Access 2007.
	Data type
	Stores
	Size

	Text
	Alphanumeric characters 

Use for text, or text and numbers that are not used in calculations (for example, a product ID).
	Up to 255 characters.

	Memo
	Alphanumeric characters (longer than 255 characters in length) or text with rich text formatting. 

Use for text greater than 255 characters in length, or for text that uses rich text formatting. Notes, lengthy descriptions, and paragraphs with formatting such as bold or italics are good examples of where you would use a Memo field.
	Up to 1 gigabyte of characters, or 2 gigabytes of storage (2 bytes per character), of which you can display 65,535 characters in a control.

	Number
	Numeric values (integers or fractional values). 

Use for storing numbers to be used in calculations, except for monetary values (use the Currency for data type for monetary values).
	1, 2, 4, or 8 bytes, or 16 bytes when used for replication ID.

	Date/Time
	Dates and times. 

Use for storing date/time values. Note that each value stored includes both a date component and a time component. 
	8 bytes.

	Currency
	Monetary values. 

Use for storing monetary values (currency).
	8 bytes.

	AutoNumber
	A unique numeric value that Office Access 2007 automatically inserts when a record is added. 

Use for generating unique values that can be used as a primary key. Note that AutoNumber fields can be incremented sequentially, by a specified increment, or chosen randomly.
	4 bytes or 16 bytes when used for replication ID.

	Yes/No
	Boolean values. 

Use for True/False fields that can hold one of two possible values: Yes/No or True/False, for example.
	1 bit (8 bits = 1 byte).

	OLE Object
	OLE objects or other binary data. 

Use for storing OLE objects from other Microsoft Windows applications.
	Up to 1 gigabyte. 

	Attachment
	Pictures, Images, Binary files, Office files. 

This is the preferred data type for storing digital images and any type of binary file.
	For compressed attachments, 2 gigabytes. For uncompressed attachments, approximately 700k, depending on the degree to which the attachment can be compressed. 

	Hyperlink
	Hyperlinks. 

Use for storing hyperlinks to provide single-click access to Web pages through a URL (Uniform Resource Locator) or files through a name in UNC (universal naming convention) format. You can also link to Access objects stored in a database.
	Up to 1 gigabyte of characters, or 2 gigabytes of storage (2 bytes per character), of which you can display 65,535 characters in a control.

	Lookup Wizard
	Not actually a data type; instead, this invokes the Lookup Wizard. 

Use to start the Lookup Wizard so you can create a field that uses a combo box to look up a value in another table, query or list of values.
	Table or query based: The size of the bound column. 

Value based: The size of the Text field used to store the value.
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